Crazy Kong PCB defekt. Hoffe auf Hilfe!

  • Hallo,


    bis vor kurzem funktionierte mein Crazy Kong Hellomat einwandfrei. Es handelt sich um ein Falcon PCB mit 2 Boards.




    Seit kurzem kommt nach dem Einschalten folgendes Standbild.



    Manchmal ändern sich die Positionen der Symbole und Zahlen wenn man aus- und einschaltet. Münzeinwurf und Player-Taste betätigen bringen keinen Unterschied. Es ist auch kein Ton mehr zu hören. Ich habe inzwischen alles, was gesockelt und gesteckt ist, gereinigt und die Elkos ausgetauscht. Hat leider keinen Unterschied gebracht.

    Hat jemand von Euch eine Vermutung woran es liegen könnte?


    Vielen Dank im Voraus!


    Viele Grüße,

    Thomas

    Es gibt 10 Gruppen von Menschen: Die, die Binärcode verstehen und die, die ihn nicht verstehen.

  • Wenn das Netzteil ok ist, also die Spannungen an der PCB stimmen, dann liegt es wohl an dieser Spieleplatine.

    Vacuum-Fachverkäufer


    Wissen ist der einzige Rohstoff, welcher sich durch Gebrauch vermehrt! :thumbsup:


    Aus aktuellem Anlaß weise ich darauf hin, daß Reparaturtips nur unter Beachtung der Regeln im Umgang mit elektrischen Geräten befolgt werden sollten!
    Sollten dort Zweifel bestehen, bitte einen Fachmann zu Rate ziehen!

  • Hallo Winni, hallo SamW,


    ich habe die Spannungen nachgemessen. Die +12V passen, von den +5V kommen 4,8V am Board an. Am Netzteil sind es noch volle +5V. Ich glaube aber nicht dass dies zum Problem führt. Glaubt ihr dass es sich lohnt, die gefühlten 5000 Lötstellen nachzulöten? Oder habt ihr noch einen gezielten Tipp. Ich möchte dieses Stück Zeitgeschichte unbedingt erhalten.


    Danke & Gruß,

    Thomas

    Es gibt 10 Gruppen von Menschen: Die, die Binärcode verstehen und die, die ihn nicht verstehen.

  • Die +4,8V am Board können sehr wohl das Problem sein.

    Die Bauteile sind für eine normale Betriebsspannung von +5V ausgelegt.

    Auf dem Board treten noch mehr Spannungsabfälle auf, durch die Länge der Leiterbahnen und Übergangswiderständen an gesockelten Bauteilen.

    Es reicht ja, wenn ein IC durch die zu niedrige Spannung nicht mehr arbeitet und die CPU deshalb nicht bootet.

    Wenn die CPU nicht startet, kann es genau so aussehen, wie auf deinem Foto.

    Du solltest die +5V am Netzteil soweit hochregeln, dass etwa +5,2V an dem Board anstehen.

    Die Bauteile vertragen eine maximale Spannung von +5,5V, da ist noch genug Reserve.

  • 5,5V ist aber mehr als mutig.


    TTL-Versorgung ist mit 5V +-5% angegeben, also 4,75V... 5,25V.


    Zitat

    Standard-TTL-Schaltkreise sind für einen Betrieb an einer Versorgungsspannung von 5 V mit einer Abweichung von 5 % ausgelegt. Gegenüber zu niedriger Betriebsspannung reagiert die TTL-Technik relativ tolerant, so dass meist auch der Betrieb beispielsweise an einer 4,5-Volt-Flachbatterie möglich ist. Noch niedrigere Werte wirken sich beispielsweise auf die Belastbarkeit der Ausgänge aus, so dass in der Regel kein stabiler Betrieb mehr garantiert ist.

    Reparaturtipps auf eigene Gefahr! Ihr seid alt genug, um zu wissen, was Ihr tut. ;)
    Strom macht klein, schwarz und hässlich... ^^

  • Danke für die Kommentare!

    Ich werde als nächstes für exakte +5V am Board sorgen und schauen ob sich etwas ändert.

    Ich melde mich dann wieder.

    Es gibt 10 Gruppen von Menschen: Die, die Binärcode verstehen und die, die ihn nicht verstehen.

  • wenn du messen kannst check mal pin 26 auf der z80 cpu (großer ic am oberen bildrand) ob der von low (0-2,5v) auf high ca. 4,5-5v springt (das passiert normalerweise innerhalb einer sek. nach dem einschalten). hast du eine logic-probe zufällig? dann könnten wir dir genauere angaben machen. ferndiagnosen sehr wage und meißt falsch. messen ist hier die klare ansage. da helfen wir dir dann weiter.


    lg tom

  • Sorry, konnte erst heute Nachmittag ein paar Dinge probieren. Habe nun ganze 4 mm² als Zuleitung zur Spiele-Platine für die +5V verlegt. Mehr als 4,9 V kommen nicht an. Ich denke, das sollte aber reichen. Da die Spannung von einem Festspannungsregler kommt, habe ich nicht allzu viele Möglichkeiten die Spannung zu erhöhen.

    Hi Tom, danke dass du dich mit einschaltest. Ich habe leider keinen Logic-Tester. Ich kann aber mit einem guten Multimeter und einem Oszi dienen. Ich werde morgen mal checken, was am Pin 26 der CPU passiert. Soll ich gegen einen speziellen Pin messen, oder gegen gesamt 0V?

    Danke & Gruß,

    Thomas

    Es gibt 10 Gruppen von Menschen: Die, die Binärcode verstehen und die, die ihn nicht verstehen.

  • So, habe soeben ein bisschen Zeit gehabt. Am Pin 26 der CPU wechselt der Pegel nach sehr kurzer Zeit auf 4,7V. Ich weiß nicht, ob das zu wenig ist. An Pin 11 der CPU (+5V) liegen 4,9V. An Pin 6 der CPU (Clock) messe ich eine Frequenz von 3,125 MHz. Ist das alles soweit OK?

    Gruß, Thomas

    Es gibt 10 Gruppen von Menschen: Die, die Binärcode verstehen und die, die ihn nicht verstehen.

  • Hi Tom, an den Pins 7-15 (ohne 11) passiert nicht viel. Manche Pins bleiben permanent auf 0V und manche Pins haben permanent +4V. Von pulsing keine Spur. Ich habe jetzt mal alle nicht benötigten Einheiten wie das Video-Chassis und die Leuchtstofflampe von der Spannungsversorgung getrennt, um eine ungestörtere Anzeige auf dem Oszi beim Einschalten zu bekommen.

    Ich bin nun der Meinung das die Spannung am Pin 26 (Reset) zeitgleich mit dem Einschalten kommt, also vielleicht zu früh.

    Gruß, Thomas

    Es gibt 10 Gruppen von Menschen: Die, die Binärcode verstehen und die, die ihn nicht verstehen.

  • Ja, bei mir ist das ein 74LS08. Die rote 2 ist übrigens eine Tantal-Perle, die zwar nicht defekt aussieht, aber von mir am Wochenende ausgetauscht wird. Mit den 10 µF könnte sie für das Timing verantwortlich sein. Ansonsten hatte ich bereits alle Alu-Elko's ausgetauscht.

    Das Gebilde an der roten 1 ist nur eine Art Lötbrücke, die auch durch Lötzinn überbrückt wurde. Somit liegt dort Pin 2 auf Masse.

    Ich melde mich nach dem Austausch wieder.

    Danke & Gruß, Thomas

    Es gibt 10 Gruppen von Menschen: Die, die Binärcode verstehen und die, die ihn nicht verstehen.

  • Bloß nicht stressen! Bis auf kurze Messungen am Patienten, habe ich auch nur am Wochenende Zeit. Ich werde mal schauen, ob ich die Logik hinter den Bauteilen richtig verstehe. Bin aber froh für jede Hilfe!

    Danke & Gruß, Thomas

    Es gibt 10 Gruppen von Menschen: Die, die Binärcode verstehen und die, die ihn nicht verstehen.