Hellomat Panel an Raspberry anschließen

  • Hallo zusammen,


    ich habe vor kurzem 3 Hellomat-Leergehäuse (ohne Monitore aber mit Panels) erstanden und möchte diese nun wieder zum Leben erwecken. Für's erste wollte ich es mir einfach machen und auf einen Raspberry und einen Zero-Delay-Encoder zurückgreifen. Jetzt stehe ich schon vor dem ersten Problem: Wie schließe ich meinen Encoder an das Controlpanel an?


    Der Button hat vier Anschlüsse mit ingesamt sechs Adern. Das Kabel von der Encoderplatine hat 2 Adern (weiß und blau). Das kann ich aber trotzdem anschließen , oder? Wenn ja, an welche Kontakte? Und interessehalber, warum hat die Originalverkabelung soviele Kontakte und Kabel/Adern?


    Ich habe auch schon im Hellomat-Thread gelesen, aber leider sind die ganzen Themen aus dem Beitrags-Index ja nicht mehr online...


    Bezüglich des Joystick-Anschlusses habe ich hier im Forum schon ein paar Infos gefunden (inklusive der Kabelbelegung). Wie und wo greife ich die Joysticksignale mit meinen Encoderkabeln am besten ab? An den Pins an denen die Originalkabel angesteckt werden? Vorher an den Schaltern? Oder an den Originalkabeln (ich würde am liebsten die Originalverkabelung nicht beschädigen, nur abziehen)?


    Im voraus schon mal vielen Dank!


    Viele Grüße


    Thorsten

  • Hallo,


    ich bin kein Experte auf dem Gebiet, aber 1 & 2 auf deinem Bild sollten für die Beleuchtung des Buttons sein und 3 & 4 für den Button selber (3 = Grund).
    Zu 1 & 2 führt je ein Kabel hin und weg, weil die in reihe geschalten werden zu einem Netzteil, selbiges macht man in der Regel auch mit dem Grund (Also Durchschleifen)


    Wenn dein Encoder je Button zwei Kabel hat, geht der Grund natürlich auch für jeden Knopf einzeln. Netzteil für die Beleuchtung bräuchtest du dann extra.


    Der Joystick sollte aus 4 Microswitches bestehen, also zwei Kabel für jede Richtung.

    Gruß

    Mraco

    Von den Schatten unserer Sorgen, wie von Dämonen getrieben, flüchten wir vor der Realität. Stürzen uns in fremde Welten,

    doch vor Schatten kann man nicht fliehen, wir sind zwischen den Welten gefangen und können der Realität nicht entfliehen.

  • Du brauchst einen Adapter auf die Steckverbindungen, an denen im Hello die Spieleplatine angesteckt wird.

    Dann kannst Du den geräteeigenen Kabelbaum nutzen.

    Die Belegung ist genormt, ebenso die Kabelfarben.


    http://www.andysarcade.de/data…erstar/hellosuperstar.pdf


    Seite 10

    Vacuum-Fachverkäufer


    Wissen ist der einzige Rohstoff, welcher sich durch Gebrauch vermehrt! :thumbsup:


    Aus aktuellem Anlaß weise ich darauf hin, daß Reparaturtips nur unter Beachtung der Regeln im Umgang mit elektrischen Geräten befolgt werden sollten!
    Sollten dort Zweifel bestehen, bitte einen Fachmann zu Rate ziehen!

  • Mraco

    Vielen Dank für die Infos. Wusste gar nicht, dass damals die Buttons schon Beleuchtung hatten; dachte immer dass das erst mit den LED-Lämpchen aufgekommen wäre.


    Bezüglich des Joysticks habe ich hier im Forum schon einen Belegungsplan gefunden:



    Mich irritiert aber die 12 V - Versorgung. Meine Planung sah eigentlich vor, irgendwo die Signale abzugreifen und wollte dazu die günstigste Stelle wissen. Geht das am Stecker überhaupt oder brauche ich auf jeden Fall eine 12 V - Versorgung?


    winni

    Das wäre natürlich die bequemste Lösung, aber das einzige was ich bis jetzt gefunden habe, war ein Adapter von Hellomat auf Jamma und dann einen weiteren Adapter von Jamma auf Raspberry was in der Summe dann nicht ganz billig wäre. Und selbst löten übersteigt leider meine Fähigkeiten (ich weiss nur, dass man das heiße Ende des Lötkolbens besser nicht anfasst...)

  • So, war am Wochenende nicht untätig und habe mal eine Testverkabelung durchgeführt. Nochmal vielen Dank an Mraco, die Buttonverkabelung hat perfekt funktioniert!


    Mit dem Joystick war es schon etwas komplizierter; ich habe die Originalstecker abgezogen und die Signale an den Pins der beiden Buchsen abgegriffen. Ich habe die Belegung vorsichtshalber zuvor durchgemessen und dabei Abweichungen zu dem Belegungsplan in meinem vorherigen Posting festgestellt (Nummerierung von links nach rechts wenn man gegen die Pins schaut):


    Buchse 1:

    Pin 1: Hoch

    Pin 4: Grund

    Pin 6: Runter


    Buchse 2:

    Pin 1: Rechts

    Pin 4: Grund

    Pin 5: Links


    Bei meinem Zero-Delay-Encoder (ZDE) sind anscheinend die Joystickfunktionen für Hoch und Runter defekt; glücklicherweise hatte ich mit Links und Rechts begonnen, sonst hätte ich die Schuld fälschlicherweise auf meine Verkabelung oder generelle Vorgehensweise geschoben.


    Eine Anmerkung noch, die vielleicht jemanden hilft: Bei meinem ZDE ist bei den beiliegenden Kabeln der Grund rot, nicht schwarz. War zuerst vom Gegenteil ausgegangen und habe mich gewundert, warum der Joystick funktioniert hat (natürlich nur in eine Richtung) solange nur eine Richtung angeschlossen war und bei zweien nichts mehr ging...


    Bin jetzt fast glücklich, wäre da nicht der fiese Input-Lag bei den Buttons. Mit einer testweise angeschlossenen Tastatur hat der Button verzögerungsfrei ausgelöst mit meinem Zero-DELAY-Encoder leider nicht. Na ja, vielleicht liegt's ja auch am Encoder, ich habe heute mal einen neuen bestellt.

  • Zero ist hier wohl nicht unbedingt zero...... fuck..... ich drücke die Daumen

    Vacuum-Fachverkäufer


    Wissen ist der einzige Rohstoff, welcher sich durch Gebrauch vermehrt! :thumbsup:


    Aus aktuellem Anlaß weise ich darauf hin, daß Reparaturtips nur unter Beachtung der Regeln im Umgang mit elektrischen Geräten befolgt werden sollten!
    Sollten dort Zweifel bestehen, bitte einen Fachmann zu Rate ziehen!