Riddle of Pythagoras - Pinout?

  • Ich hab da ein kleines Problem mit einer Riddle of Pythagoras-Platine.


    Die war in einem TopGame mit entsprechendem Adapter und ich wollte einen Jamma-Adapter daraus basteln. Nachdem ich heute in Lascheks Scan-Projekt eine Datei mit dem Pinout gefunden habe, hab ich heute Abend locker flockig alle Kabel abgelötet und mich darn gemacht, alles an ein Jamma-Fingerboard zu löten. Spannungen, ganz viel Masse, aber oh Schreck...da stimmt was nicht.


    Wie man anhand der Bilder erkennen kann, ist auf dem großen Anschluss an der Stelle, wo die Buttons sein sollen (laut KLOV hat das Spiel nur einen Button!? aber im Pinout sind ja auch unnötigerweise up/down/left/right eingezeichnet), keine Kabel. Das wären die Position 8 von links gezählt im Vordergrund und 7 im Hintergrund. Und ein Pinout für die kleine Tochterplatine fehlt leider auch. Ich schätze mal, dass da die Steuerung dranhängt...und zwar sowlhl für den Spinner als auch für den "Feuerbutton".



    Hat jemand auch so eine Platine (original Sega) und kann mir sagen, wie die Kabel hier beschaltet sind?


    Danke :)

  • OK, anhand des ICs auf der Huckepackplatine hab ich herausgefunden, dass ganz rechts am Anschluss +5V sind (gelb) und der vierte von rechts GND (weiß). Das passt auch zum restlichen Farbschema der Anschlüsse, aber 100% sicher kann man da ja nie sein.


    Dann gehe ich mal davon aus, dass rot und blau für den Spinner zuständig sind und der rosa Draht für den Button. Weiß wird dann halt nochmals GND sein. Das kommt zumindest beim Durchklingeln als Ergebnis raus ;)

  • Der Link geht nicht :D
    Ich hab eine solche PCB und kann ggf. nochmal nachschauen, bin mir aber grad nicht sicher ob da auch ein Adapter dabei ist.

  • Ist OK, ich hab sie gestern Abend in Betrieb genommen :)
    Anschlüsse auf dem daughterboard wie vermutet.


    Soll ich dir das geänderte bzw. erweiterte Pinout zukommen lassen? Dann könntest du das bei KLOV und in der Datenbank aktualisieren.


    edit: Link funzt jetzt....

  • Moin, bin gerade daran meinen Spinner an die Riddle of Pythagoras anzuschliessen.
    Habe wie oben im Bild 2 den Spinner und den Button angehängt.


    Button funktioniert, Spinner tut leider keinen Wank.
    Spinner funktioniert mit meiner Arkanoid Platine einwandfrei.


    Was könnte das sein?


    5V und 12V sind soweit in Ordnung.


    Danke für eure Zeit...

  • Konnte noch die Grundplatine tausche mit meiner Transformer Platine, funktioniert aber auch nicht.
    Auf der Spinner Platine ist ja fast nichts drauf, 2x TTL und 1x D4701AC und paar Widerstände.


    Habe GND nur einmal angeschlossen, den Pin 15 habe ich mir gespart.
    Die Pins 15/16 und 4 sind ja miteinander verbunden und der Button funktioniert auch einwandfrei - nur der Spinner tut keinen Wank.


    Ideen?

  • Glaube ich nicht, 5V / GND / Li / Re mehr ist da ja nicht.
    Die Anschlüsse auf dem Daughter-Board und dem Spinner stimmen überein.


    Danke trotzdem für den Gedankengang! :-)

  • 5V auf dem Spinner Addon Board passt soweit - danke.
    Bin leider immer noch nicht weiter hier... :(


    Kann es sein, dass der Taito Spinner nicht kompatibel ist?
    Was hast du für einen Spinner an deinem Riddle of P. dran Luigi?

  • Luigi/Thorsten ist hier nicht mehr aktiv... :(


    Also ein Spinner der mit Arkanoid funzt sollte definitiv auch mit Riddle of Pythagoras laufen, ist bei mir zumindest so.
    Vorausgesetzt natürlich dein Stecker vom Riddle Board hat das gleiche Pinout wie bei Arkanoid, das solltest du definitiv nochmal checken. Mein Spinner hat auf den äusseren beiden Pins die Drehrichtungen und innen 5v und GND. Mag auch andere geben.
    Dann noch die obligatorische blöde Frage von mir :D :
    Du sagst du hast dir GND Pin 15 gespart..., aber am Spinner hast du schon GND angeschlossen?


    Ansonsten sind detailreiche Bilder von der Verkabelung oder vom Spinner etc. immer hilfreich.

  • Ja, angeschlossen ist alles korrekt, dass steht schon mal fest.
    Ein Kollege aus der Schweiz hat mich mit Fotos versorgt und die Anschlüsse stimmen überein.


    Er verwendet aber einen "moderneren" Taito Spinner mit mehr Elektronik auf der Sensor Platine.
    Meiner hat bloss 2x 150Ohm Widerstände und die beiden Optos...anscheinend hat ein "universal" Spinner noch zusätzlich Pulldown (oder up) Widerstände drauf.


    Bekomme die Tage noch Antwort von einem Italiener deswegen...schauen wir mal.


    Danke schon mal für deine Hilfe...:)

  • Ja aber ist doch wurscht was der für einen Spinner nutzt, du musst das Pinout von DEINEM Spinner rausfinden und dementsprechend anschliessen. Also einfach mal anhand deines Arkanoid Adapters/Kabelbaums die Belegung rausfinden und dementsprechend den Riddle verkabeln.
    Wenns dann nicht geht wird halt evtl. was auf dem Riddle Board kaputt sein.

  • Angeschlossen ist es richtig - 100% , habe mich nicht genug deutlich ausgedrückt oben.


    Mein Spinner (alte Taito Revision): https://www.dropbox.com/s/lyu4…10-03%2013.39.03.jpg?dl=0
    Universal Spinner und Taito Spinner (neue Version) die bei meinem Freund funktionieren:
    http://arcade-system.com/image…/spinner-pcb-arcade-2.jpg
    https://www.dropbox.com/s/3ahi…qo/taito_spinner.JPG?dl=0


    Der Italiener hat mir geschrieben, dass Riddle of P zwei zusätzlich Pulldown Widerstände braucht (ca. 1 kOhm), damit der Encoder D4701 die Signale korrekt erkennt.
    Dies ist anscheinend auf den Taito Platinen (Arkanoid, Arkanoid DOH) direkt richtig integriert.


    Werde dies mal testen und wieder berichten.


    Danke!