Tutorial GroovyMAME + CRTEmu Driver + ASIO4ALL

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • u-man schrieb:

      Was genau meinst du mit: "Der PC startet immer in 1024x768, auf dem desktop is es dann aber 640x480@60hz."
      Für mich klingt das so, als wäre der BIOS screen 1024x768 und der windows desktop screen dann 640x480. Falls das so ist, würde ich versuchen den BIOS screen auf klassisch umzustellen. Das dürfte nicht so hoch ausfallen .
      Danke für den Tipp mit der pci-Grafikkarte. Leider ist 1024x768 die kleinste Auflösung die das UEFI verwenden kann. Oder gibt es da außer der Auflösungseinstellung noch einen anderen Modus, der dann wie ein altes richtiges BIOS aussieht? Dann nämlich hätte sich auch das mit der pci-graka erledigt, wird ja dann bei nem VGA/TriSync Monitor überflüssig und wäre nur noch bei nem Low Res Monitor nötig.
      Weis jemand wie man so einen BIOS-Modus bei nem ASRock Z97 Mainboard einstellt?
    • Also ich hab bzgl. der BIOs Auflösung bzw. Darstellung nix gefunden. Ich kann bei AsRock nur zwischen HD-Modus und 1024x768 wählen und dann kann ich noch den Bootbildschirm zwischen Logo und standard Bootsequenz wählen.
      Hat einer ne Ahnung obs da doch was verstecktes oder so gibt? Hab mir jetzt mal noch ne ATI Rage 128 VRL PCI-Grafikkarte bestellt. Wieso funktioniert das eigentlich nur mit einer PCI-Grafikkarte und nicht mit der OnBoard Grafik?

      EDIT:
      Ich habe eben den ASIO4All installiert und konfiguriert.
      jetzt kommt zwar sound wenn ich ne mp3 starte, aber in MAME ist alles still.
      Was hab ich falsch gemacht? Wie gesagt das Mainboard ist das selbe wie im TUT und installiert hab ich´s auch danach.
      Die GroovyMAME version ist auch die selbe.

      Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Shadolf ()

    • u-man schrieb:

      Die günstigste und meinr meinung nach beste lösung ist, sich eine billige pci grafikkarte zu besorgen (achtung keine pci-e karte) . kostet max. 10euro, eher weniger. im BIOS gibt man diese als "primary graphics adapter" an. Dann passiert folgendes. Beim start findet der rechner die karte, da aber nichts angeschlossen ist, bleibt der bildschirm aus und zwar solange bis windows gebootet ist. Windows wird automatisch erkennen wo ein bildschirm dranhängt und dann habt ihr auch wieder (safes) bild .

      Ich habe jetzt die PCI-Grafikkarte eingebaut und im UEFI den Primari Grafik Adapter auf PCI umgestellt, aber er schaltet im Windows dann nicht um auf die PCIe Grafikkarte. Wenn ich dann im Windows den Bildschirm an der PCI-GraKa anschließe und auf Bildschirmauflösung gehe erkennt er mir da auch nur diese Grafikkarte. Im Gerätemanager unter Grafikkarte sind aber beide aufgelistet.
      Muss ich dazu noch etwas umstellen? Kann ich dem Windows nicht irgendwie sagen welche Grafikkarte es verwenden soll?

      Update:
      Ich habe jetzt mal im Gerätemanager die PCI-GraKa deaktiviert, aber er nutzt weiter diese, nur die Bezeichnung ändert sich. Auch wenn ich an beiden Grafikkarten Monitore anschließe kommt nur Bild bei der PCI-Karte. Die andere ist zwar erkannt als Hardware, taucht aber auch bei den Displayeinstellungen nicht auf (da wo man die Auflösung, Primärmonitor etc. einstellen kann). Allgemein schaut es aus, als würde nur noch die GPU funktionieren die im UEFI/BIOs als Primär eingestellt wird.

      Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von Shadolf ()

    • Shadolf schrieb:

      Also ich hab bzgl. der BIOs Auflösung bzw. Darstellung nix gefunden. Ich kann bei AsRock nur zwischen HD-Modus und 1024x768 wählen und dann kann ich noch den Bootbildschirm zwischen Logo und standard Bootsequenz wählen.
      Hat einer ne Ahnung obs da doch was verstecktes oder so gibt? Hab mir jetzt mal noch ne ATI Rage 128 VRL PCI-Grafikkarte bestellt. Wieso funktioniert das eigentlich nur mit einer PCI-Grafikkarte und nicht mit der OnBoard Grafik?

      EDIT:
      Ich habe eben den ASIO4All installiert und konfiguriert.
      jetzt kommt zwar sound wenn ich ne mp3 starte, aber in MAME ist alles still.
      Was hab ich falsch gemacht? Wie gesagt das Mainboard ist das selbe wie im TUT und installiert hab ich´s auch danach.
      Die GroovyMAME version ist auch die selbe.
      Du musst im ASIO4ALL die richtige Soundkarte/Ausgang auswählen.
      In meinem Tutorial bin ich da auch genauer drauf eingegangen.

      Bei dem Problem mit den zwei Grafikkarten kann ich leider nicht weiterhelfen. Bin ich überfragt. Selbst über eine Google Suche gibt es zur Grafikkarten Priorisierungen kaum Infos.

      EDIT: Eventuell mal das Catalyst Control Center installieren. Dort ist vielleicht eine Einstellung diesbezüglich zu finden.
      support.hp.com/de-de/document/c03051920

      Dort kannst du im CCC dann einer Grafikkarte eine Anwendung zuweisen. D.h. du könntest deinem Frontend und mame die ATI Karte zuweisen. Wenn du das Frontend als Shell oder im Autostart hast, solltest du ein Bild beim Starten bekommen.

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von evidencedj ()

    • Shadolf schrieb:

      u-man schrieb:

      Die günstigste und meinr meinung nach beste lösung ist, sich eine billige pci grafikkarte zu besorgen (achtung keine pci-e karte) . kostet max. 10euro, eher weniger. im BIOS gibt man diese als "primary graphics adapter" an. Dann passiert folgendes. Beim start findet der rechner die karte, da aber nichts angeschlossen ist, bleibt der bildschirm aus und zwar solange bis windows gebootet ist. Windows wird automatisch erkennen wo ein bildschirm dranhängt und dann habt ihr auch wieder (safes) bild .
      Ich habe jetzt die PCI-Grafikkarte eingebaut und im UEFI den Primari Grafik Adapter auf PCI umgestellt, aber er schaltet im Windows dann nicht um auf die PCIe Grafikkarte. Wenn ich dann im Windows den Bildschirm an der PCI-GraKa anschließe und auf Bildschirmauflösung gehe erkennt er mir da auch nur diese Grafikkarte. Im Gerätemanager unter Grafikkarte sind aber beide aufgelistet.
      Muss ich dazu noch etwas umstellen? Kann ich dem Windows nicht irgendwie sagen welche Grafikkarte es verwenden soll?

      Update:
      Ich habe jetzt mal im Gerätemanager die PCI-GraKa deaktiviert, aber er nutzt weiter diese, nur die Bezeichnung ändert sich. Auch wenn ich an beiden Grafikkarten Monitore anschließe kommt nur Bild bei der PCI-Karte. Die andere ist zwar erkannt als Hardware, taucht aber auch bei den Displayeinstellungen nicht auf (da wo man die Auflösung, Primärmonitor etc. einstellen kann). Allgemein schaut es aus, als würde nur noch die GPU funktionieren die im UEFI/BIOs als Primär eingestellt wird.
      Mmmh, das tut mir Leid das du solche Probleme hast. Ich stelle mal ein paar dumme Fragen:

      1. Hast du Treiber für die PCI Karte installiert? Ich benutze in meinen Setups keine.
      2. Hast du eine CPU mit Grafik-Prozessor? Ich habe keine oder aber habe diese explizit ausgeschaltet im BIOS.
      3. In welchem PCI-E Slot steckt deine PCI-E Grafik-Karte? Meine steckt im ersten.

      Sind nochmal Ansätze, vielleicht ist was brauchbares für dich dabei. Ich habe zwei Setups, wo das alles problemlos funktioniert.
    • @evidencedj: Also das mit dem Sound klappt jetzt. Weis auch nicht wirklich woran es gelegen hat. Hatte beim erstenmal alles nach deiner Anleitung gemacht. Hab jetzt im ASIO nur den Lautsprecherausgang aktiviert gelassen. Das wird es wohl gewesen sein. Aber ausserhalb MAME hatte der Sound ja auch zuvor funktioniert. echt komisch Es sollte doch möglich sein im ASIO auch 2 Ausgänge zu aktivieren. Wenn ich z.B. noch zusätzlich n Kopfhörerausgang nutzen will. Werd das bei gelegenheit nochmal testen. Das mit dem CCC schau ich mir jetzt dann an, bin mit der pci-Grfikkarte immer noch nicht weiter gekommen, hatte aber auch keine Zeit.

      @u-man:
      1. Nein habe keine Treiber installiert.
      2. Ja, ich habe fast das selbe Hardware-Setup wie im TUT. Ich kann im BIOS (UEFI) halt wie schon geschrieben beim Primären Grafikkontroller zwischen Intern also onboard, PCi und PCI-e wählen. Andere optionen gibts diesbezüglich nicht, ausser die sind gut versteckt vor mir ;)
      3. PCI-e Karte steckt im ersten, die anderen haben alle den kurzen Slot.

      Ist das AsRock in dem Fall wohl nicht so ganz geeignet!? Ich werde aller vorraussicht nach noch weitere dieser Systeme in andere Cabs verbauen. Was gäbe es den alternativ für vergleichbare Mainboards (auch Preislich)?



      EDIT: Also versuche seit ner Weile verzweifelt das CCC irgendwie zu installieren. Klappt nicht, da man das nur in Verbindung mit dem Kompletten AMD-Treiberpaket kann. Hab versucht es irgendwie hin zu mauscheln ohne Treiber. Jetzt sagt es beim Versuch die CCC.exe zu starten: "AMD Catalyst Control Center cannot be started. There are currently no settings that can be configured using AMD Catalyst Control Center."
      Wie hast du das geschaft das CCC zu installieren in kombination mit dem CRT-Emudriver evidencedj? Wieso kanns nicht einfach mal alles funktionieren wie es soll :(

      Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von Shadolf ()

    • Mir wurde eben im ArcadeOtaku ans Herz gelegt das Bios meiner Grafikkarte einfach mit ATOM-15 zu flashen und im Bios die zulässigen Frequenzen festzulegen. Funktioniert nicht schlecht. Dann wird während des Bootprozesses nur eine Auflösung der in der Grafikkarte einprogrammierten Frequenzen verwendet. Im Windows übernimmt dann der Treiber, in unserem Fall der CRT-Emudriver. Ist das hier im Forum noch nicht bekannt? Wenn nicht mach ich vielleicht mal n Thread dazu auf. Ist echt nützlich und man spart sich das Geld für ne 2te PCI-Grafikkarte oder den J-Pac.

      Ich hab noch eine Frage wegen der Frequenzen im CRT-Emudriver. Ich habe alles nach anleitung gemacht. Jetzt habe ich halt im Windows scannlines. Wenn ich den PC an meinene Sony Trinitrons oder anderen Fernseher anschließen will passt dass ja. An meinem Toshiba TriSync wäre es mir allerdings lieber ich habe das Windows und Programme wie die Emulatoren in 640x480 31khz, so dass im GroovyMAME nur die 15khz Frequenzen entsprechend der gestarteten Roms verwendet werden. Was muss ich dazu machen?

      Antwort: ArcadeOSD.exe die im CRT-Emudriver dabei ist starten. Bei den Modes den letzten der custom-modes mit einem p (nicht i) aktivieren. Den Monitor mit den potis hertikal und horizontal zentrieren und einstellen (ohne Overscan). Dann sollten die anderen Modi alle zentriert und auch ohne Overscan angezeigt werden. Dann wenn man Windows in 640x480p 60Hz dargestellt haben will, den Mode aktivieren und übernehmen (Menüpunkt im ArcadeOSD). Fertig :)

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Shadolf ()

    • @evidencedj:
      Wäre super wenn du ein upgedatetes Tutorial für GM 0.182 schreiben würdest. Soll ne Menge neuer Funktionen etc. haben. Nur bei den englischen Tuts bin ich mir immer nicht zu 100% sicher das ich alles richtig versteh.
      Geht ja jetzt irgendwie ohne ASIO.
      Oder muss man einfach ne neue Installation von GM erstellen und dann den ganzen CRT Emudriver stuff etc. machen wie in deinem Tut zu 0.171 nur das halt eben das ASIO weg fällt?!
    • Habe mir gestern Abend mal die aktuellste Version parallel eingerichtet. Mit der neuen Portaudio Implmentierung merke ich keinen Unterschied zu ASIO. Schon mal sehr gut. Einen d3d9ex Build für GroovyMAME gibt es auch. Ich hatte sogar den Vorteil, dass ich beim Beenden von GroovyMAME keinerlei Verzögerungen hatte, wenn ich zum AttractMode Frontend zurückkehre. Ein großer Vorteil.
      Ich aktualisiere mein Tutorial, respektive ich schreibe ein Neues, sobald ich das ausgiebig getestet habe.
    • wenn ich das erstmal alles mit einem TFT außerhalb des Cabs machen möchte lasse ich den Part mit dem CRT Emudriver aussen vor?

      muss ja mal erst sehen ob das alles so klappt wie ich nes mir vorstelle.

      in deinem Downloadfiles 3x4 GB sind dochj nocr Foto und videod dateien drin oder auch roms, ich habe hier ja noch welche liegen kann ich die einfach beutzen?
      Magnum 2x 6 Player Button Layout mit RGB Led's, Bartop von Arcadeforge, V Pinball 46 Zoll 3Screen Setup


    • moin,

      so mal wieder etwas zeit zu schreiben.

      also...in den download files sind keine ROMS!! die gibt es zuhauf über Google zu finden. Wichtig ist nur, dass du passende ROMS zu deiner MAME Version findest. Letzen Endes sind es aber nur eine handvoll ROMS, die bei abweichenden Versionen nicht laufen.

      Wenn du es erstmal am LCD testen möchtest, bietet sich das ganze ohne CRTEmuDriver an. Aber, wenn du keinen Grafikkartentreiber installiert hast, kann es sein, dass MAME erst gar nicht läuft. Solltest du einen regulären Treiber installieren, so muss dieser vor der Installation des CRTEmuDriver KOMPLETT deinstalliert werden. Da ist ein bisschen Vorsicht geboten, sonst hakt sich das mit den EmuDrivern. Da gibt es aber Tools im Netz, die einem dabei helfen.

      Grüße
    • ich hab heute mal die Arcade VGA Karte ausgebaut und durch eine HD4670 (Atom-15 Flash) getauscht.
      Treiber 2.0 sind alle richtig installiert.
      ich habe die ArcadeVGA getauscht weil ich immer Thearing in der Grafik hatte bei 100% Emulation,
      wenn ich vsync eingeschaltet hatte war die Emulation immer auf 102-110% je nach Spiel.
      Jetzt läuft alles auf 100% ohne Thearing.
      nur ich habe ein großes Problem mit der geometrie bei jeder auflösung ist der Bildschirm anders verzehrt.
      Ich habe zwar das Tool Arcade OSD gesehen weis aber nicht genau wie das funktioniert.
      das hatte ich zwar gelesen aber das klappt bei mir nicht so


      Antwort: ArcadeOSD.exe die im CRT-Emudriver dabei ist starten. Bei den Modes den letzten der custom-modes mit einem p (nicht i) aktivieren. Den Monitor mit den potis hertikal und horizontal zentrieren und einstellen (ohne Overscan). Dann sollten die anderen Modi alle zentriert und auch ohne Overscan angezeigt werden. Dann wenn man Windows in 640x480p 60Hz dargestellt haben will, den Mode aktivieren und übernehmen (Menüpunkt im ArcadeOSD). Fertig

      Gruß Olaf
    • ich versteh nich ganz was du mit verzerrt meinst.
      Bei mir ist es so, dass ich in Groovy Mame erstmal bei jedem Spiel die horizontale Einstellung vornehmen muss.
      Ist so weil man ja die Super Resolutions mit den 2560x... nutzt.
      Ich hab in Windows 320x240 eingestellt und das ist auch meine Basis nach der ich meinen Bildschirm eingestellt habe.
      Also in Groovy Mame ins Menu unter Slider Controls gehen und dann bei Screen Horiz Stretch auf ca. 0.510 stellen und nochmal mit Screen Horiz Position zentrieren.
      Je nach dem was deine Vertikale Zeilenzahl ist musst Vertikal auch nochmal reduzieren.

      Bei Spielen die dann z.B. die Auflösung 384x224 haben wie die CPS2 spiele, ist dann oben und unten ein kleiner schwarzer streifen.
      Das mit den Streifen lässt sich nicht ändern, wenn du alle spiele in ihrer original auflösung spielen willst.
      Was ich hier aber noch probieren will ist Windows auf eine Auflösung mit vertikal 224 zu stellen, da man in MAME die Screen Vertical Stretch reduzieren kann.
      Man kann also alle spiele die dann vertikal mehr als 224 haben und somit zu beginn über den bildschirm hinaus gehen vertikal auch wie horizontal anpassen.
      Das ist aber nur eine Vermutung die ich erst selbst noch testen muss.
    • ja ist immer sehr schwer zu erklären.
      beispiel ich hab raiden zentriert mit dem monitor,
      wenn ich jetzt twincobra starte ist das bild nach rechts versetzt.
      Raiden=256x224 Switchr. 2560x240p 59.600hz 15.675khz
      Twincobra=320x240 Switchr. 2560x240p 54.878hz 15.640khz
      mit Arcade OSD müsste es doch möglich sein das Bild anzupassen ohne das ich jedesmal die Hinterwand vom Automaten entfernen muss und neu zu justieren.
      bei der ArcadeVGA war das bild fast zu 98% immer mittig wenn es nicht stimmte gab es das tool arcadeperfect damit konnte ich das bild verschieben ohne was am bildschirm zu drehen.
      ich meine arcadeperfect und ArcadeOSD sollten ja das gleiche tun aber verstehe das ArcadeOSD nicht finde dazu auch keine richtige anleitung.
    • Ich muss es selbst nochmal alles im ArcadeOSD machen, dass ich keinen blödsinn erzähle.
      Aber wenn du nochmal anpassungen bei den einzelnen Spielen brauchst, dann mach die immer im Menü von MAME und nicht am Monitor.
      Bin grad dabei mir das GroovyMAME 0.192 drauf zu machen. Hab auch mal kurz ins ArcadeOSD geschaut. Werd mal die Roms auf den neuesten Stand bringen und dann die Sache nochmal komplett durchziehen. Mach das alles heute noch, bzw. JETZT.

      Vielleicht kann ich ja mal ein kleines Tutorial fürs ArcadeOSD etc. machen und evidencedj baut das irgendwie bei seinem TUT mit ein oder sowas.

      EDIT:
      Also ich hab eben mal im ArcadeOSD rumgedoktert und versuchs nochmal Schritt für Schritt zu erklären.
      1. ArcadeOSD.exe starten.
      2. Mit den Pfeiltasten Videomodes anwählen und Enter drücken.
      3. Mit den Pfeiltasten die 15khz Frequenz mit der niedrigsten Yres auswählen+Enter, bei der Vfrq noch ein p und kein i stehen hat. Ist bei mir 320x240 60p 60.001Hz 15.660KHz. Hier soweit ich weis eben keinen der SuperResolutions mit 2560 wählen.
      4. Dann den Monitor mit den Potis bzw. dem Monitor OSD so einstellen, das eben der Rot-Grüne Hintergrund mit dem weißen Gitter genau den Bildschirm ausfüllt.
      5. Dann den Punkt "Set as desktop mode" anwählen und Entern. Im erscheinenden Menü dann "Keep" anwählen und wieder Entern. Jetzt sollte der Windows-Desktop den Bildschirm genau ausfüllen.
      6. Groovy MAME starten und dann eben für jedes Spiel das du Spielen willst die Breite und evtl. die Horizontale Position über das Menü einstellen. Vertikal geht hier nur kleiner machen. Wenn man die schwarzen Streifen oben und unten nicht will, die man so bei einigen Spielen mit geringerer Vertikaler Auflösung als 240p bekommt, braucht man eine SuperResolution bzw. einen Mode der hier eben z.B. 224p hat. Das geht aber soweit ich weis nicht oder nur mit bestimmten Grafikkarten. Dann muss man aber im ArcadeOSD dann auch diese x224p bei der Bildeinstellung auswählen und das Windows in diesem Mode darstellen bzw. darstellen können.

      Beantwortet das deine Fragen Olaf?

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Shadolf ()